148 Posts
MtnPavlas
7 months ago
5
Topic

When creating or editing an article on the front end, upon clicking the user icon on the "Created By" field, the modal loads an error page with the following error:

View not found [name, type, prefix]: users, html, site

In the console, I see it could not load the following: https://www.evergreenmtb.org/manage/blog/form/index.php?option=com_users&view=users&layout=modal&tmpl=component&required=0&field=blog_created_by ... is it because "/manage/blog" gets inserted (i.e., the view URL gets constructed implicitly vs. from the root)?

Thx

Get a VIP membership
42 Posts
StanislavR
6 months ago
0
Level 1

Hi

There is a problem 

What are the chances that they will fix it? 

I really need it

best regards

6 months ago
0
Level 1

Hi,

We're currently checking this issue and comme back to you asap.

Regards

148 Posts
MtnPavlas
6 months ago
0
Level 1

Thank you, Olivier and Seblod team - please keep us posted as this is a major bug for many, I'd imagine. 

6 months ago
1
Level 1

Hi everyone,

Using the "Form user" field on the front is really not ideal.

One of the best solutions is to create a "Select Dynamic" field which will retrieve the list of users you want and set this field instead for your site form. You can even add some magic js to have an autocomplete or other extra features.

Regards,

148 Posts
MtnPavlas
6 months ago
0
Level 2

Thanks, Olivier. WIth all due respect - it's a classic Seblod BS answer... so there's a standard Joomla field that natively works in both admin and front end - Seblod recreates that field, except at some point it gets broken, and instead of fixing it, the answer is to stop using it. It's like out of a bad movie, TBH.

But I'll bite - I'm happy to use your suggested solution... except, scrolling through thousands of user names in the drop-down is not an option - can you please share the JS/jQuery solution you had in mind? I also tried Pulsar's/Cyril's multi-autocomplete, but it doesn't work in our installation any longer for some reason (it used to work fine on older versions).

Thank you.

Get a Book for SEBLOD