This site uses cookies and similar technologies.

If you don't change browser settings, you agree to it.

I understand
111 Posts
jimenaes
3 years ago
3
Topic

Hi

I'm working with a content type with many fields (73) and suddenly if I edit it from the site view I can't add any text to the wysywyg editor fields beacuse I get a blank page with the error 1118 message:

 (..."Row size too large (> 8126). Changing some columns to TEXT or BLOB or using ROW_FORMAT=DYNAMIC or ROW_FORMAT=COMPRESSED may help...")

I have changed all my wysywyg editor fields datatype to TEXT but doesn't work. Does anybody have any idea how to solve this? Is there a text fields limit in Seblod per content type?

Thanks

Get a Book for SEBLOD
3 years ago
1
Level 1

Hi jimenaes,

there is no limitation in SEBLOD which would give you an Mysql error.

By cons, Mysql have some limitations.

By default, most of SEBLOD fields have the type "VARCHAR(255)", so what I advise here, is to check all your fields to give them the better type, depending on their utility. (TINYINT, DATETIME,....)


Regards.

Lionel

111 Posts
jimenaes
3 years ago
0
Level 2

Hi, thanks for answer. yes, I did check the fields types and change all the wysiwyw to type "TEXT()" (without character limit) but the error remains.

3 years ago
0
Level 1

Hi Jimenaes,

I was not only speaking about wysiwyg field, but for all your form fields.

VARCHAR(255) take lot of space, and often it's not needed. So for example, if you have a field Select with options like "My Text 1=1 / My Text 2=2...", it's better to set the column as something like 'TINYINT(3)".

I think, if you adapt correctly all your field you will close this issue.

Regards.

Lionel

Get a VIP membership