This site uses cookies and similar technologies.

If you don't change browser settings, you agree to it.

I understand
67 Posts
Bonitto
1 year ago
11
Topic
  • Hi,

I am not sure when did this issue start happening however I am having an issue whenever I try to add or remove fields within Group X. I tried to look up and see how anyone else solved past issues similar to this but none of the solutions have worked for me. 

I can confirm that I am able to see the Group X add and remove icons however when I click them nothing happens. I have also checked the console log to see if I can find any error however I don't see any.

Any help you could provide would be greatly appreciated.

I am currently running on:

  • Joomla 3.7.4
  • SEBLOD 3.11.3
Get a Book for SEBLOD
4228 Posts
Kadministrator
1 year ago
10
Level 1

Is this back or fronendt? If nothing happens this is most likely javascript issue, either Seblod scripts are not being loaded or some other script is overriding click handler attached to the buttons. Try disabling extenions and template functions one by one to see which one is causing this, usually suspects are system plugins and optimization functions in templates. 

67 Posts
Bonitto
1 year ago
9
Level 2

This is on the backend. I do have one warning in my console log: 


util.js:221 Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

but I can't see how this would be causing the issue. I will try disabling system plugins as you suggested.

4228 Posts
Kadministrator
1 year ago
8
Level 3

Google now requires keys for maps, geolocation or similar scripts, so it could also be an old version of address to location plugin that is causing this. And any javascript error will cause other scripts that come after it to fail, this is why group X does not work for you.

67 Posts
Bonitto
1 year ago
7
Level 4

Ok I have found that the problem is that I am using the SEBLOD list field which I have set to reference a single location on a map that matches the address coordinates. Once I removed this field, the Group X add/remove functionality was able to work again. Now while removing the field at gives me a sense of direction I am not sure how do I get my single list map view to display correctly without the same error. I can confirm that I already put in my API key in SEBLOD's address to coordinates plugin but that error still displays.  Did SEBLOD ever update this?

4228 Posts
Kadministrator
1 year ago
6
Level 5

First please check if you have the latest version of the field.

67 Posts
Bonitto
1 year ago
5
Level 6

I have the latest version of Form and List Pack 1.5.1 installed. I also have the latest version of the Map template installed.

4228 Posts
Kadministrator
1 year ago
4
Level 7

I'm asking about address to coordinates field - missing api key message can only come from it or from map template that also needs api key.

67 Posts
Bonitto
1 year ago
3
Level 8

I do have my API key published in the map template and plugin as well.

4228 Posts
Kadministrator
1 year ago
2
Level 9

I'm afraid that without looking at the problem on the site it is impossible to tell what is causing this. 

67 Posts
Bonitto
1 year ago
1
Level 10

Ok so I removed and added my API key and the warning seems to have gone away but now there's another problem.

My problem is the map location icon doesn't work on this page: https://dev.cloudaccess.host/locations/diagnostic-imaging-centers/rai-lawrenceville but it works on all of the other location pages.

I provided you with a login to see for yourself Klas. 

4228 Posts
Kadministrator
1 year ago
0
Level 11

Hi,

sorry, but it is too much javascript on that page to know what is causing this.

Get a VIP membership