WeStandWithUkraine

11 Posts
etnr
2 years ago
12
Topic

Hello guys, I need help. With the last update, the submit button is not being shown to the guest when editing. After the guest fills out the form he receives an email with a link that allows him to edit some information. I have several forms like this that worked normally. Now when the guest accesses the form through the link, the information appears but the submit button does not, so he is unable to submit again. I appreciate anyone who helps me.

Get a Book for SEBLOD
1 Post
Chesa
2 years ago
0
Level 1

I am experiencing a similar problem, Can anyone help regarding this?

332 Posts
Kenneth
2 years ago
10
Level 1

Hi.

First of to the both of you. What content type are the forms creating? (article, user, category?)

11 Posts
etnr
2 years ago
9
Level 2

Hi Kenneth! Free content type.

332 Posts
Kenneth
2 years ago
8
Level 3

Can you please check under permission if guest is set to be able to create?

11 Posts
etnr
2 years ago
7
Level 4

Hi Kenneth, thanks for responding. Yes, the permissions are ok. Just remembering that the button does not appear only when trying to edit an existing record. To include, it appears normally. All of my forms were working perfectly before the update and I haven't changed anything in the permissions since then. The most curious thing is that I made a backup of the site that is on hostgator and installed it on my localhost server and everything works normally, that is, the button appears normally in the edition. What can this be?

332 Posts
Kenneth
2 years ago
6
Level 5

Several things come to mind:

  • Could the setup be out of date vs. server versions (PHP etc?)
  • Some firewall on hostgator is blocking the buttons action (I would have contacted them to have a look)
11 Posts
etnr
2 years ago
5
Level 6

I verified that this is only happening with the guest. If I log in with an administrator user the button appears. In the list of bugs fixed in this version, something related to this appears. This did not happen before with the guest.

332 Posts
Kenneth
2 years ago
4
Level 7

Could you please share some screenshots of the permission settings for the content type? If possible I could also log into your backend and have a look around?

11 Posts
etnr
2 years ago
3
Level 8

332 Posts
Kenneth
2 years ago
2
Level 9

Hmm.. that's quite strange. I'm sorry I have no other suggestions other than asking hostgator if they could be the reason for this.

11 Posts
etnr
2 years ago
1
Level 10

Hi Kenneth, thank you very much for your attention!
I discovered the problem!
It was the native joomla cache plugin. I remembered that I was doing some tests a while ago and I deactivated the cachecontrol and activated the native joomla plugin. I came back as I was before and everything went back to normal.

332 Posts
Kenneth
2 years ago
0
Level 11

Ah, of course! :)

Nice to see it solved!

Get a Book for SEBLOD