11 Posts
Maago
7 months ago
6
Topic

Hi,

I have created a form for frontend editing with validations. This is not working. I cannot save such a form. In browser console this error appears:

If I disable validations I can save the form.

Get a VIP membership
120 Posts
root
7 months ago
2
Level 1

This is due to javascript errors.

Or you have some misspelling in the validations, or you have another javascript error in the same page of the form which is not allowing the other scripts to work properly.

Kind regards

11 Posts
Maago
7 months ago
1
Level 2

Hello,

the only thing I changed is that I installed Joomla 4.4.1 Update (from 4.4.0). Maybe there is something changed which makes the validations unusable in frontend?

I don't think it is a javascript error on other elements because as I said - if I disable the validation everything works.

11 Posts
Maago
7 months ago
0
Level 3

This is the script where it tells me error:

"Uncaught SyntaxError: missing } after property list"

<script>(function ($){
$(document).ready(function(){$("#cck1r_chm_platz").conditionalStates({"states":[{"type":"isHidden","selector":"","revert":"1","value":""}],"conditions":[{"type":"isEqual","trigger":"kategorie","value":"Sonstiges,Kaufen und Verkaufen"}],"rule":"and"});$("#cck1r_anzahl_personen").conditionalStates({"states":[{"type":"isHidden","selector":"","revert":"1","value":""}],"conditions":[{"type":"isEqual","trigger":"kategorie","value":"Kaufen und Verkaufen,Sonstiges"}],"rule":"and"});$("#cck1r_zeitraum").conditionalStates({"states":[{"type":"isHidden","selector":"","revert":"1","value":""}],"conditions":[{"type":"isEqual","trigger":"kategorie","value":"Sonstiges,Kaufen und Verkaufen"}],"rule":"and"});});})(jQuery);</script>
<script>jQuery(document).ready(function($){ $.validationEngineLanguage.newLang({"required_autor_email":{"regex": "none","alertText":"* Bitte Email Adresse"},"_tabs":{"regex":"","alertText":"<small>Please check <span>red</span> tab(s).</small>"}});$("#seblod_form").validationEngine({scroll:true,promptPosition:"topRight"}); });</script>

120 Posts
root
7 months ago
0
Level 1

Hi,

This would be good to know... although Joomla 4.4.1 is a security update, in seblod.com still says "Compatible up to: Joomla 4.4.0". This could be the problem, but I can't help you with this. I have all the production sites (that use seblod) not updated because of this. It's name is fear x_D

Can you try with a copy of the site not updated, I mean in joomla 4.4.0?

If you disable javascript validation in seblod and load the form with the browser console, is there any other javascript error in that page?

7 months ago
1
Level 1

Hi guys,

Thank you for the report. SEBLOD 4.2.0 is released and should fix the validation issue (at least for English & French) on J! 4.4.1

ref: https://github.com/Octopoos/SEBLOD/commit/d418c5b8da88eaaaaad4f8e68bf51fe8ecb2bcd7

Saba

11 Posts
Maago
7 months ago
0
Level 2

Wow, that was fast. Thanks a lot. I confirm it is working now.

Get a Book for SEBLOD