WeStandWithUkraine

26 Posts
jsfernando
6 years ago
11
Topic

Field Email Form! Problem with SEBLOD 3.7.2 and 3.5.1 J. No email is sent. I have some sites using SEBLOD I updated to 3.5.1 :( I get the error ". 0 - invalid address" after sending forms Any suggestions on a solution.?

Form - Email "Error: 0 Invalid address:" Based solution on the forum joomla, which could be implemented in the email field SEBLOD ... /plugins/cck_field/email/email.php Report on JMail class and one addReplyTo array (array ($ replyTo, $ replyToName)) 

http://forum.joomla.org/viewtopic.php?f=708&t=917253&p=3386537#p3386640 

Some help!!!

Get a VIP membership
4229 Posts
Kadministrator
6 years ago
2
Level 1

Seblod is not yet compatible with joomla 3.5, you need to wait for seblod 3.8 to be released.

26 Posts
jsfernando
6 years ago
1
Level 2

Klas, 

There is no workaround for it problem before it gets out version 3.8? I like to be the only problem in the Email field? I have 3 applications stops ... I know it was my fault have updated joomla unaware of the complication of SEBLOD ... now it has been ...

Tks

4229 Posts
Kadministrator
6 years ago
0
Level 3

sorry, we don't have a workaround

4229 Posts
Kadministrator
6 years ago
6
Level 1

Please make a screenshot of your email field configuration, I tried and I can't replicate this with current development version, but it might be you are using different configuration, we would like to make sure it works.

26 Posts
jsfernando
6 years ago
2
Level 2

Klas, 

here it is...

4229 Posts
Kadministrator
6 years ago
1
Level 3

Hi

I can't see your screenshot, you need to upload it.

26 Posts
jsfernando
6 years ago
0
Level 4

Klas,

I could not attach here.
So will the image link

http://prntscr.com/ars5bo

26 Posts
jsfernando
6 years ago
2
Level 2

Klas,

the error appears in the email protoca field, which through the form override is captured an email

to j version! 3.4.8, it was working normally

Tks

4229 Posts
Kadministrator
6 years ago
1
Level 3

You have an error in your field configuration, in the To field you should enter en email adress, not filed name protoca_email. Field name belongs only to To(fields) field.

26 Posts
jsfernando
6 years ago
0
Level 4

Klas,

It was good your observation, redid the settings.
I have 3 applications (forms) to send mail.
A Form the Send E-mail field is Always, it did not work
A Form the Send E-mail field is ADD, that did not work
In another the Send E-mail field is to Add and Edit
In another have 4 E-mail fields are 2 to Send E-mail Add the other 2 to Edit.
In the latter case only works 2 fields that are the Send E-mail Edit

The images are examples of Send E-mail Always and then changed to add only and did not work ...
Screenshots:
http://prnt.sc/aslscw
http://prnt.sc/asltlf


I will make another post cases that functioned as Edit and Add not ...

Based on its analysis, there is still some misconfiguration!

Thank you,

117 Posts
deralex
6 years ago
0
Level 1

I've had the same problem and solved it (for me):

Seems that in earlier J! versions there was a validation for mail addresses which now has gone. As soon as there's a wrong mail address either in your field configuration or in an input field, J! throws an error and breaks down.

I don't know if that's something that will be solved by the J! team soon. The solution within SEBLOD is quite easy: Every value that is expected to carry a mail address should be validated ($from, $dest, $cc, $bcc) right before the mail is being sent in plugins > cck_field > email > email.php in line 510.

Get a VIP membership