WeStandWithUkraine

71 Posts
Filip
9 years ago
Topic
Hi


First and foremost, thanks for all the help here so far... i know my newbie questions are basic! Now, onwards to my next problem.


I have created an field for uploading multiple images (using field x). Everything works great up until the display stage on the content pages, the files gets uploaded and thumbnails are created. The problem i have is that only one thumbnail is displayed on the content page. When clicking on the thumbnail to view the full picture, the box indicates that there are more pictures, but when clicking on next it all crashes. 


Any ideas why this may be happening?


Help would be greatly appreciated!


Get a VIP membership
9 years ago
3
Level 1

Hello Filip,

can you post screenshots of your fields storage configuration:

  • The Field Upload Image
  • The FieldX field.


regards.

Lionel

71 Posts
Filip
9 years ago
2
Level 2

Here are the screenshoots:


Field X

http://policydatabase.boku.ac.at/images/Field_X.jpg

Image upload

http://policydatabase.boku.ac.at/images/image_upload.jpg


The storage does however seem to work OK. The images are uploaded and the modal box even detects that there are several images to display, it just crashes after displaying the first image. For example, a second picture just shows up as a broken link on the content page (see pic below).


Content page

http://policydatabase.boku.ac.at/images/thumbnail.jpg


Thanks!

9 years ago
1
Level 3

Hello Filip,

the storage is not good. You save the two field in the same column.


The image Filed must have NO storage.

and for the fieldX, the storage must be :

Custom |  Article  |  database_field_column[field_name]


regards.

Lionel

71 Posts
Filip
9 years ago
0
Level 4

Got it to work :)


Thanks once again for the help Lionel!!


3 Posts
Sergey_kov
7 years ago
1
Level 1

I have the same problem, I don't knowwhat to do, please help! Meyour methoddid not help!I would like to addthat when theXeditFieldcan displayonly onefirst picture, whileeverything is fine.

3 Posts
Sergey_kov
7 years ago
0
Level 2

Finallyfound the cause, a column in the databasewhereyoustoredfieldX, if youputvarcharlengthmore, for exampleI set1024and it worked!!!

Get a VIP membership