This site uses cookies and similar technologies.

If you don't change browser settings, you agree to it.

I understand
112 Posts
MtnPavlas
1 month ago
2
Topic

Dear Sebloders, this topic has been addressed a couple times in the forum, but none of the solutions apply to our situation so I thought I'd post this.

We have about 10 content types on our website (evergreenmtb.org), and most work like a charm.

However, 2 content types ("Article" - out of the box Seblod content type, and "Chapter" - one of our custom content types) started to give us trouble upon save just recently, i.e. the user can get to the edit form, but upon save the updates do NOT save, and the user is taken to page <site root>/component/cck

Couple highlights:

  • Versions: Joomla 3.8.3, Seblod 3.17.5, all Seblod plugins seem to be up to date (don't see any in Seblod Updater needing an upgrade)
  • It's not permissions - they are set correctly for the content type and the category; this is happening to Super User, too (who has all permissions on by default per Joomla's ACL)
  • Gzip is off
  • All JS, CSS minification is off
  • All caching is off (in global config, all plugins)
  • I don't see any obvious javascript/jQuery conflicts in Chrome developer console
  • The "Article" content type is using all native Seblod/Joomla fields, nothing crazy (e.g. no fields with JS or jQuery)
  • If, instead of "Save and close", I hit "Cancel", it leads to the same result (i.e. goes to <site root>/component/cck) ... I'd think at least cancel would work fine

Any ideas on what else I could try to adjust, or how I could narrow down the root cause? I'm happy to bump your permissions if anyone would like to create a user account, and see the issue for yourself. Much appreciated.

Get a VIP membership
112 Posts
MtnPavlas
1 month ago
0
Level 1

Dear Octopoos team, any ideas please? I just bought the paid membership in hopes to get a bit of support, but wasn't sure which private forum section to post this under so I went with the public option. I'd be grateful for any pointers. Again, the weirdest thing is that saving works just fine for most of our content types, but two of them.

112 Posts
MtnPavlas
1 month ago
0
Level 1

I narrowed down the conditions under which this issue takes place. It only happens if I edit content item that has a dedicated menu item for it (i.e. menu item "Single Article"). Couple use cases:

  1. Menu item is created for a list/search page: User visits the page, clicks on the link on one of the items listed on this page; it takes them to the content item, user edits this content, content item saves just fine.
  2. Menu item is created for a specific content item (i.e. article): User visits this page, edits the content item, content item does NOT save, user is taken to <site base URL>/component/cck

Any thoughts?

Dear Seblod team, I even bought your membership, hoping to get a response : (

Get a VIP membership