8 Posts
Taki
6 years ago
4
Topic

Hi,

I am trying to create a subform that allows the user to edit only their first_name and last_name. I have created a form object type none, added the 2 fields to it with a save button. 

The profile changes to the subform fields only upon save. The fields are however updated correctly. How do i change this?

Taki

Get a Book for SEBLOD
8 Posts
Taki
6 years ago
1
Level 1

Changing the cck field back to user in tables _cck_store_item_users and _cck_core seems to solve the problem. I'm thinking of just writing a script that updates these fields after each save as a temporary solution.

1283 Posts
Bucklash
6 years ago
0
Level 2

Hi

As a concept, seblod has one form per content type. 

If I was to use a dummy form like you did then I would create a content type  with storage none, then do all processing with beforestore or afterstore fields. 

Or on 'genuine' conent type form, create override on positions so that only certain fields display on the conditions that I set....

4229 Posts
Kadministrator
6 years ago
0
Level 1

You can't have multiple forms saving to the same tables. What you can do is to use restriction plugins  from ACL pack to restrict fields for user that is not in  some user group. E:g. if you have fields a,b,c,d you can put admin group restriction on e.g. c and d - this way only admins will see all four fields and normal user  will get only a and b fields.

8 Posts
Taki
6 years ago
0
Level 1

Thanks for your reponses.

I've decided to stick updating tables _cck_store_item_users and _cck_core with afterstore for now. 


Maybe there can be an option to not update those tables for all dummy forms?......   ;)

Get a VIP membership