WeStandWithUkraine

3 years ago
10
Topic

Hello

For an unknown reason when a manager (not an admin) tries to edit some contents in backoffice I get this error message:

Data integrity check failed, you are not allowed to save this item.
For security reasons, you can't edit more than one content (from the same Content Type/Form) in different tabs of your web browser. An error has occurred.

however I can garantee that there is NO other content edited by this manager in the web browser. The error is elsewhere.

Here are some additional infos:

  • the error only occurs on some contents
  • if I edit this 'faulty' contents as an admin and then try to re edit is as the manager, the error disappears
  • If I set this manager user as an admin , the error disappears
  • there is NOthing locked in the whole site
  • I use J 3.9.4 + seblod 3.17.3
  • If I remove ALL the fields in the admin form, just leaving the title, the error remains.

Thanks for your help

Cyril

Get a Book for SEBLOD
4 Posts
greif.bar
2 years ago
0
Level 1

SAAAAME HERE!

126 Posts
Cappu
8 months ago
8
Level 1

Hi Cyril,

I do have this error in one of my applications, now September 2021. - Could you solve the problem?

85 Posts
root
8 months ago
7
Level 2

Hi Cappu,

Have you tried by completely clearing the browser cache?

Kind regards

126 Posts
Cappu
8 months ago
6
Level 3

Hi @root, thanks for the hint. I tried that, but without success. :-(

6 months ago
5
Level 4

Hi! I have this error too but only if:

1) User uses the website through a VPN (Citrix) and if the user is not an admin

So if the user runs it outside citrix it works

If the user runs it in citrix with Editor rights it does not work. With admin rights it works

I found the file /libraries/cck/base/form/store_inc.php where this error message is enqued and it seems it looks for a hash, but my finding does not really bring me forward:

if ( $toBeChecked && !in_array( $field->name, $config['options']['data_integrity_excluded'] ) ) {
			$hash		=	JApplication::getHash( $value );
			$hashed		=	$session->get( 'cck_hash_live_'.$field->name );
			$session->clear( 'cck_hash_live_'.$field->name );
			
			if ( $hash !=  $hashed ) {
				$config['validate'] =	'error';
				$integrity[]		=	$field->name;
			}
		}

5 Posts
Visit-D
6 months ago
4
Level 5

Brilliant

6 months ago
3
Level 6

Not sure if this is brilliant :-) Did it bring you forward? If so, please share what to do :-D I don't want the user to give admin rights...

5 Posts
Visit-D
6 months ago
2
Level 7

Brilliant means just to see there is somebody still alive. My skills are to low  to fix your problem, but I know people who know people who knows. Please give me a week.

5 Posts
Visit-D
6 months ago
1
Level 8

Hi Elisa,

to circle the problem we need some further Information. Please give us all details about Your Citrix VPN settings. Have You tested other VPN connections?

Cyril reported a similar problem not depending on VPN, so please post Your Seblod Integration Settings relating to Articles, Categories, Users and User Groups.

Are You creating/editing only SEBLOD Content/Users or both? 

How are Joomla Sessions handled?

Did You test the edition behaviour after TRUNCATE of the session table and clearing the browser cache?

Have a nice Sunday

Tom

6 months ago
0
Level 9

Hi Tom, it's not my Citrix Configuration but from the customer, I have almost no possibility to find out more about it. Clearing Cache and Purge Sessions does not help. It's clearly reproduceable like written above:

No Citrix: Admin and Editor works

Citrix: Only Admin works

Session handling is through Database.

Seblod Integration Settings: Content Object is Article, Default Content Type is everywhere none, Edit Link is everywhere auto

Get a VIP membership