WeStandWithUkraine

9 Posts
cbahiana
7 years ago
Topic

It's Joomla 2.5.27 install running Seblod 3.3.7. We've been using Seblod for a specialised form that feeds six sub-categories of a category. 

From a certain day on Seblod contents from these categories displayed the uninterpreted code. New contents were Ok. I dug a little into it and concluded that the relation between the pk field in #__cck_core had lost synch with the id field in #__com_content. As we had had a database problem a few days ago and had to restore a backup (Akeeba Backup), something might had gone wrong and would explain the problem.

The thing is, though: contents that were showing Ok yesterday today also show uninterpreted code. If I create a new content it shows Ok.

Get a VIP membership
7 years ago
0
Level 1

Hi! What do you mean with uninterpreted code. Just ::cck::: things or the plain code? 

1) Did you set error reporting on ?

2) Any Scriptconflicts on your site?

3) Did you clear your Browsercache?

Regards,

Elisa

449 Posts
gebeer
7 years ago
2
Level 1

Before you restored the DB from your backup, had there been any changes like adding fields to your form etc.?

This can easily end up in a mess like you are experiencing it.

If possible, you should revert to the complete backup, not only update the DB. And then recreate all the changes that you made since then.

9 Posts
cbahiana
7 years ago
1
Level 2

Hi gebeer,

Yes, the article's title was based on the original art_title field, then I changed it to use a custom text field storing it's content inside title at com_content table. Was this then?

I managed to recover the situation by running insert queries on cck_core which restored the relationship between id, cck, pk, storage_location, author_id and parent_id. Fortunately it was a few dozen articles, not hundreds... ;-)

449 Posts
gebeer
7 years ago
0
Level 3

Glad you could solve it :)

Get a Book for SEBLOD