WeStandWithUkraine

3 Posts
petedenly
5 years ago
4
Topic

I have just updated Joomla to latest version 3.7.0 from previous version.

Also updated php to 7.1.1 from 5.6.30.

I now have the warning message when creating new article pages from a seblod template.

-----

Warning: Declaration of JCckTable::getFields() should be compatible with JTable::getFields($reload = false) in /Applications/MAMP/htdocs/Europastamps3/libraries/cms/cck/table.php on line 78

-----

Line 78 appears at the end of this file with no code.

This site build is on more than one computer and is ok on one machine but not the other.

Any ideas what could be wrong?

Many thanks

Pete Denly

Get a VIP membership
3 Posts
petedenly
5 years ago
3
Level 1

Found with general search for warning.

Have solved this problem by:

You could also change line 38 of libraries\cms\cck\table.php from

public function getFields()

to

public function getFields($reload = false)

Cheers

Giuse

4229 Posts
Kadministrator
5 years ago
2
Level 2

Seblod is not compatible yet with 3.7., you need to wait for next release. For this error the above fix will work.

28 Posts
Marco Heinski
5 years ago
1
Level 3

A quick communication on the homepage of the site would avoid many inconveniences.

Saudações

Marco

4229 Posts
Kadministrator
5 years ago
0
Level 4

Hi, yes, I agree with you, I'll forward this to site admins.

Get a VIP membership