This site uses cookies and similar technologies.

If you don't change browser settings, you agree to it.

I understand
101 Posts
webchun
1 year ago
Topic

HI, I added generic 'Search' field to my list and then I published a seblod search module. The module's search function doesn't work when I enabled SEF from global configuration. But when I disabled SEF the search function is working properly.

The search function from list itself is working good.

Here is the comparation of generated urls :

http://xxx.com/rtrwj/component/cck/?cck=mylist&mylist_search=test&search=mylist&task=search --> Using search input from module, doesn't work

http://xxx.com/rtrwj/list-mylist?cck=mylist&mylist_search=test&boxchecked=0&search=mylist&task=search --> Using search input from list page, working good

Is it a bug or I'm missed something?

Thanks!

Get a Book for SEBLOD
4229 Posts
Kadministrator
1 year ago
2
Level 1

So basically you are saying search generic doesn't work when search is displayed in the module?

101 Posts
webchun
1 year ago
0
Level 2

yes, exactly

101 Posts
webchun
1 year ago
0
Level 2

Hi Klas, are you able to reproduce the issue?

4229 Posts
Kadministrator
1 year ago
1
Level 1

I tested - you need to set menu item target in module to menu pointing to your search type.

101 Posts
webchun
1 year ago
0
Level 2

Ah ok. Thanks Klas!

101 Posts
webchun
1 year ago
2
Level 1

Hi Klas, Now I have the opposite issue. When SEF is ON the module is working good and the search form in the list page is not. 
The urls are also switched. List page now generates component/cck/?cck=mylist&mylist_sear... url and module generates list-mylist?cck=mylist&mylist_search=test&box 

I have tried some combinations in the menu parameters and still doesn't work. Do you have any idea?

101 Posts
webchun
1 year ago
1
Level 2

Hmm I think this is joomla 3.8.4 bug. I tried to update the joomla version to 3.8.5 and now it's working properly

4229 Posts
Kadministrator
1 year ago
0
Level 3

Yes, it was joomla 3.8.4 problem.

Get a VIP membership