16 Posts
tonnick
7 years ago
30
Topic

Hello !

I am trying to build a user list with a link to the user's profile. But I get totally lost, and there is no tutorial or forum subject which could describe how to manage that. :(

Could you please indicate the steps to build such link ?! thx for your help !

Get a VIP membership
4229 Posts
Kadministrator
7 years ago
13
Level 1

You can link any list to the item view by applying link to the field (button 2 on the right) and setting it to the View

16 Posts
tonnick
7 years ago
12
Level 2

Sorry but I am still confused.

You can link any list to the item view by applying link to the field (button 2 on the right) and setting it to the View

You mean, when I am my list&search, in vue-search option-field, I edit the field "user name" for exemple, I put type : link ? but link to what ?

4229 Posts
Kadministrator
7 years ago
11
Level 3

In list and search go to your List tab (or item if your template is blog). Then click button 2 on the right to switch to links editing and select View from dropdown on the field. Seblod will link list to the single item view automatically. 

I recommend you wantch this video from James Morell

https://www.youtube.com/watch?v=hYTzPL61GuU

16 Posts
tonnick
7 years ago
10
Level 4

ok thx ! I did but I still don't have link on my text :(

572 Posts
_jrmo
7 years ago
9
Level 5

Hi tonnick,

I think there might be some confusion here. Please go to the video that Klas linked, and watch from 4:10 - it describes the EXACT steps to do this.

https://www.youtube.com/watch?v=hYTzPL61GuU

thanks,

James

16 Posts
tonnick
7 years ago
8
Level 6

hello james,

yes maybe there is some confusion, but I don't know where. if you chech my screenshot, I am on same way than video and klas recomandations :

list&type search >> user >> item tab >>  link+typo button (2) >> modify link >> content >> see

Any idea where I get wrong ?

572 Posts
_jrmo
7 years ago
7
Level 7

And you are saying that in the front end of your template there is NO link at all? not even an incorrect one?

I don't see how that's possible, unless you are using a template override, or a javascript that is removing all links or something like that.

16 Posts
tonnick
7 years ago
6
Level 8

yes this is what I'm saying :

http://bbfc.alcalina.net/index.php/les-membres

And I don't think that template removes the links ;)

572 Posts
_jrmo
7 years ago
5
Level 9

You're going to have to do some debugging here:

1. Try removing your heading typography on the text, and instead put the HTML typography with <a href="/$cck->getLink('user_name');">*value*</a>

2. Try with any other link type and see if it works

16 Posts
tonnick
7 years ago
0
Level 10

ok seems to be better, I have a link with first option, but to home page :( 

18 Posts
rippe
6 years ago
3
Level 10

Hi,

just as tonnick I wasn't presented the user profile, but was directed to the root of localhost (wamp-server).

Clean Joomla! and SEBLOD.

Thanks in advance

4229 Posts
Kadministrator
6 years ago
2
Level 11

This is most likely related to the permissions - if buyer does not have a permission to edit users there will be no link. As you are forcing a link with typography you will get one, but it will be empty. So check edit  permission of the user.

18 Posts
rippe
6 years ago
1
Level 12

Hi Octopoos - Klas,

Even as Super User I am directed to localhost... See attachment.

Thanks.

18 Posts
rippe
6 years ago
0
Level 13

Sorry, here it is...

Thanks.

4229 Posts
Kadministrator
6 years ago
1
Level 1

In list and search go to your List tab (or item if your template is blog). Then click button 2 on the right to switch to links editing and select View from dropdown on the field. Seblod will link list to the single item view automatically. Remove any typography you have on this field, also don't forget to click on + and select right menu for the link.

18 Posts
rippe
6 years ago
0
Level 2

Hello again and thank you for your answer,

I have done so several times, but the list just becomes a "dead" list. In the previous post I had followed someone's tip to choose Typography: HTML and copied & paste some HTML code. This gave me clickable fields, but they directed me to localhost. See attachements.

Also, I do not know what I should do in this "+ menu"...? 

Cheers!

572 Posts
_jrmo
6 years ago
3
Level 1

hi there,

Try turning off SEF URLs and URL rewriting. This might be an issue while on your local host.

James

18 Posts
rippe
6 years ago
2
Level 2

Thanks James,

However, it doesn't work anyway :-(

I m really stuck here.

//Richard

572 Posts
_jrmo
6 years ago
1
Level 3

It sounds like a local issue. Move your site to a live server and test it there. It looks as though you are doing the right thing and there's just an issue with your localhost setup.

18 Posts
rippe
6 years ago
0
Level 4

Hi _jrmo,

I have moved to a live server and tested just about everything now, puh! I have:

* Turned on/off SEF.

*Tried with link: view and some options on the '+' sign (but I don't really know what to change here).

*Set Typography to HTML and put in: <a href="/$cck->getLink('user_name');">*value*</a. In this case I do get a link on the user, but it still goes to the root.

I'm out of options here. Obiously I'm doing something wrong but I can't figure out what.

Best regards,

Richard

4229 Posts
Kadministrator
6 years ago
6
Level 1

Hi,

one thing - did you activate user bridge? It might be list links are not working without it and if I recall correctly only users created after bridge can be seen in the list. 

18 Posts
rippe
6 years ago
5
Level 2

Thanks Klas,

It wasn't activated, so I did. However, no user will appear at all when this is activated. Not even if I create new ones afterwards. No Bridge is activated, all columns have "view" under link and "none" under typography. Is that correct setting? Under the "+" beside "view", I am using default values. Is that wrong?

//Richard

18 Posts
rippe
6 years ago
4
Level 3

Hi,

Update: I disabled the bridge, and then I got links on two users. However, the links goes to the user's articles (none in this case) and not the user info. 

I'm getting more and more confused :-O

//Richard

188 Posts
uriel
6 years ago
3
Level 4

I do so.

I turn on the bridge> Default Title user_name use.

In lists, open the list (users)
In list and configuration
SEF = / alias

In Item and Fields, 2, let View. I click the +
In Sef = / alias

menu item (user)

then with PHP you can create links

as on my website >

http://oceanoliterario.com/

18 Posts
rippe
6 years ago
2
Level 5

Thank uriel for the answer,

Unfortunately, following your instructions (down to the PHP-thingy which is something I do not master) just made the user list disappear, as before. I'm using list with "table" template that make the "Item" disabled, so I did the changes to the "list" instead with the above result :-(

Other suggestions? Perhaps something that is basic and obvious to you guys that I have missed...

//Richard

188 Posts
uriel
6 years ago
1
Level 6
188 Posts
uriel
6 years ago
0
Level 7

create Item menu category (users)

18 Posts
rippe
6 years ago
2
Level 1

Strange! 

When I disabled SEF the list came back with links to those created after SEF was enabled, BUT... the very same user who registrated the other users how now authority to do so anymore, AND new users registrated from back-end does not have the link to the user....!?

Any ideas?

Thanks,

//Richard

18 Posts
rippe
6 years ago
1
Level 2

Thans for the video uriel, I'll go through it properly. I didn't see it until now.

When I as a Super user on Back-end registred a new user, the following error was attached.

(The text under "Nyheter" should be some demo news)

//Richard

18 Posts
rippe
6 years ago
0
Level 3

SOLVED!

I'm not really sure what I did, but I fiddled around a lot with the tips that you guys gave me. The error in my last post (where I obviously forgot to attache  the picture), was no error. Even if I am a newbie I understood with a bit of reading that I enabled some kind of debug function; it was the MySQL query :-)

Now that all in working... how can I modify the information in the article showing up when following the user link? I added a lot of information, but all of it does not appear. Also I would like to move the information about the user (Joomla user..., Details..., Category...and so on) from the top to the bottom of the page... if possible.

Thanks a lot, you are the best!

//Richard

Get a Book for SEBLOD