1283 Posts
Bucklash
7 years ago
7
Topic

Hi folks

If I have a menu item that is a Search and List, does the INITIAL link have to have all the params in it to function properly - it seems so...

Example:

https://fretroom.com.au/lesson-files/transcriptions

if I select an option in the Search Form, the url pre-fills with all the correct params.

ie: Select Title of Article...which has the id as value (eg 238)

https://fretroom.com.au/lesson-files/transcriptions?cck=lesson_file&lesson_file_filter_title_transcription=&filter_file_types=13&filter_bands_and_artists=&filter_notation_formats=&lesson_file_search_generic=&filter_bands_and_artists_generic=&art_id=238&boxchecked=0&search=lesson_files_list&task=search

However, pagination does not. Pagination leaves the url empty but appends "start=24".

Pagination only works if the url params already exist unlike the select box options which magically prefill the url 

That make sense?

Is there something I could do?

Thanks

Jon

Get a VIP membership
4229 Posts
Kadministrator
7 years ago
1
Level 1

Hi,

it is not clear from your description which pagination is not working for you - the one set in list configuration, override from menu or pagination limit set with Search pagination plugin

1283 Posts
Bucklash
7 years ago
0
Level 2

Hi Klas

It's the one set in list configuration...

If I click on say page 8 of 9, would it ordinarily only append the url value with start=12 or start=24 etc...

or would/should/could it normally append with "cck=lesson_file&lesson_file_filter_title_transcription=..." and then append 'start=12' etc?

The image below shows pagination appending the url with "start='some number'".

Should I recreate my url with all the search criteria to begin with?

4229 Posts
Kadministrator
7 years ago
0
Level 1
4229 Posts
Kadministrator
7 years ago
2
Level 1

I needed this working for a project so I made a pull request :) 

https://github.com/Octopoos/SEBLOD/pull/361

1283 Posts
Bucklash
7 years ago
0
Level 2

Nice!

2 Posts
Stech
6 years ago
0
Level 2

Awesome Job Klas.

I have implemented the solution that you wrote in the Commit and it works great also for the AJAX Load-more
http://linkcom.stech.site/product-table-test

But it does not work using the "List & Form" field plugin with a list within a list
http://linkcom.stech.site/magnetics/xdsl-g-fast?magnetics_subtype=xDSL_G.fast

This might be a very different topic thread, that I have not found any one addressing so far.

4229 Posts
Kadministrator
6 years ago
0
Level 1

You can't have read more on list within the list, that is a bug that it even shows for you (you can have readmore on parent list, but not on children).

Please write just in one thread in the future.

Get a Book for SEBLOD