215 Posts
7 years ago

I love Seblod! And it makes me feel like a noob from time to time... 

So hoping you'll tolerate a noobish question.

I created a simple search and for some reason the Select Query is shown above the search form and results, like so -- why? is there a switch for this? is it contagious?

BTW, I checked 

  • the templates (just using the standard seblod_table template for a list) AND
  • there is no module showing the SQL query, AND
  • SQL Select statement is still rendered with a NEW menu item, AND
  • The SQL Select statement as NO style, or class, or ID, else I'd just use CSS to hide it.

Hmmm.... this appears to be generated by default from some component function, no?

thx -- Dano

SELECT t0.id AS pid,t0.pk AS pk,t0.pkb AS pkb,t0.parent_id AS parent,t0.author_id AS author,t0.cck AS cck,t0.storage_location AS loc,tt.id AS type_id,tt.alias AS type_alias
FROM `#__cck_core` AS t0
LEFT JOIN `#__cck_store_form_applicants` AS t1 ON t1.id = t0.pk
LEFT JOIN `#__content` AS t2 ON t2.id = t0.pk
LEFT JOIN `#__cck_core_types` AS tt ON tt.name = t0.cck
WHERE t2.state = 1
AND t2.access IN (1,1,2,3)
AND ( t2.publish_up = '0000-00-00 00:00:00' OR t2.publish_up <= '2017-02-26 01:52' )
AND ( t2.publish_down = '0000-00-00 00:00:00' OR t2.publish_down >= '2017-02-26 01:52' )
AND t0.cck = 'applicants'
AND t1.position LIKE '%Processor%'
ORDER BY t2.created DESC

Get a VIP membership
4229 Posts
7 years ago
Level 1

Turn of debugging in component options->Site tab or in search type configuration (depends where you enabled it)

215 Posts
7 years ago
Level 1

Thanks Klas,

Event though Debug was turned OFF globally (set to None), I still had to set search type configuration = NO (setting it as Global did not work)


43 Posts
6 years ago
Level 2

Hi, where is this setting, could you provide a screenshot where it is, or guide


4229 Posts
6 years ago
Level 3

For global option see manual, for option for each list go to Configuration tab.

Get a Book for SEBLOD