WeStandWithUkraine

41 Posts
mlep
4 years ago
Topic

Hi Sebloders,
I have a basic issue but I can't solve it... Shame on me !

I would like to get a list of name based on "date of death" calendar field.
Format field is d-m-Y
Storage format : Date time
Show Time : No
Default H M S : 00:00:00

In my datebase, the stored field is e.g 1942-11-08 00:00:00

So when I search a list with 08-11-1942 date of death, I have 0 result. The debug shows : AND t1.date_of_death = '1942-11-08 10:14:38'

The matching operator with button 3 is Exact, so it is normal that there is 0 result, because of time.

My question is : could somebody tell me why I have the current time (10:14:38) and not the default time (00:00:00) of the field option ? How to solve that ?

Thanks a lot

Get a Book for SEBLOD
4229 Posts
Kadministrator
4 years ago
3
Level 1

Which calendar field is this (there are 2 - one from Joomla and one from Seblod)?

41 Posts
mlep
4 years ago
2
Level 2

Seblod one I think because it is stored in a _cck_store_form_  database

4229 Posts
Kadministrator
4 years ago
1
Level 3

Storage doesn't matter, is it "Calendar" or "JForm - Calendar" type?

41 Posts
mlep
4 years ago
0
Level 4

calendar type

41 Posts
mlep
4 years ago
2
Level 1

Does something change in Seblod calendar field in 3.15 version ? I thought my search form was working before...

Thanks for any help !

4229 Posts
Kadministrator
4 years ago
1
Level 2

Hi,

nothing has changed since few months. Please report this on the github tracker, I will take a look.

41 Posts
mlep
4 years ago
0
Level 3

Done, Thanks a lot Klas

41 Posts
mlep
4 years ago
2
Level 1

Hi again,

Could someone tell me how to apply DATE format for data of a seblod calendar field. I just found DATETIME or TIMESTAMP in field options, not DATE. I still have an issue with matching operator EXACT because of summer/winter hours. 

I don't understand why this field give the default time when the calendar is used and the current time when I manualy fill the date (d-m-Y format) into the field ???

Thanks for replies !

4229 Posts
Kadministrator
4 years ago
1
Level 2

Hi,

with calendar field you can't search by the date only.

Your alternatives are to disable manual input and allow calendar only or use normal text field with some javascript calendar addon like this: http://www.jamesmorrell.com/blog/seblod-datepicker-calendar

Also take a look at https://github.com/Octopoos/SEBLOD/issues/474

41 Posts
mlep
4 years ago
0
Level 3

Many thanks Klas. You sent me on the right way.

In format, I used d-m-Y| so when I put my date manually, time is 00:00:00 !

I still had a problem with local hour, resolved by changing the location of the server.

Get a Book for SEBLOD