40 Posts
yoyoxp
7 years ago
Topic

I have noticed that after updating to Seblod 3.9 I can no longer set limit via select field which generates property: '?limit=XX'. Before under 3.8.4 this does work. Is this a bug or by design? I do notice under changelog for 3.9 that some limit related fixes were introduced

Cheers,

Nick

Get a Book for SEBLOD
40 Posts
yoyoxp
7 years ago
0
Level 1

This bug also affecting Seblod 3.9.1. Is there any solution but to downgrade to 3.8.4? I also notice that Random articles module does not work right under the latest versions. The issue is not all articles under a particular content type are considered, so it will repeat the same content over and over again (it will show only 5/6 articles out of a pool of about 400!).
Will there be a resolution for these issues? If you need any further information please let me know! :)

4229 Posts
Kadministrator
7 years ago
12
Level 1

It is still possible to use limit variable if limit is not set in the configuration - so remove limit in your content type configuration and it will work.

40 Posts
yoyoxp
7 years ago
11
Level 2

Cheers Klas,

Limit under Search & list type has always been set to 0 as I am using pagination in combination with limit filtering overide. But, doing a bit more digging I seem to have found the bug/issue..

Seblod seems to be taking the pagination value as limit value, which in turn means setting &limit=XX is not taking effect, but also for random articles the SQL query is applying limit same as set for pagination. See attached for an example of my random article module working, while pagination is set to '500'. SQL query has limit set to value of pagination limit. Pagination does work:
http://imgur.com/a/8mRmU

Hopefully this is enough to help investigate. My site is not online atm but if you need access let me know and I'll see what I can do.

4229 Posts
Kadministrator
7 years ago
10
Level 3

Limit you see in the query will be whatever value is smaller, limit sets overall limit to number of items, but if pagination value is smaller you will see pagination number in the query as one of the reasons for pagination is to get better performance by splitting a number of items in smaller units.

40 Posts
yoyoxp
7 years ago
9
Level 4

Hi Klas,

I understand the explanation and reasoning. I took it to understand limit of '0' under Search type represented display all, but if I set it to 999999.. all items are included. This does fix the random item problem mentioned earlier. Really I have used this thread to discuss multiple problems, and this is confusing so my apologies :) .
Unfortunately this change does not resolve the error of being able to override the limit parameter via ?limit=XXX variable in the URL string, thus changing the pagination and number of items displayed per page. This is a requirement for me and worked well under Seblod 3.8.4. could you check this?

Many thanks,

Nick

4229 Posts
Kadministrator
7 years ago
8
Level 5

Hi,

try removing any limits (both limit and pagination) in the list configuration, set this limits in the menu or module if you need them. This way you can override it at other places.

40 Posts
yoyoxp
7 years ago
7
Level 6

Cheers Klas,

Tried that, but no joy I'm afraid. I produced pdf document you can check here: http://irishcallcards.net/seblod-limits.pdf. Is there anything wrong with my configuration?

Cheers,

Nick

4229 Posts
Kadministrator
7 years ago
6
Level 7

In the menu go to the Options tab. There you have options for limit and pagination, set limit t0 0 and pagination to All items. Then your limit should work.

40 Posts
yoyoxp
7 years ago
5
Level 8

no joy I'm afraid, still the limit variable don't work. Really I don't think this is a problem with my configuration. Why is there no problem under Seblod 3.8.4?

4229 Posts
Kadministrator
7 years ago
4
Level 9

Hi,

just answering to let you know that I'm currently investigating this issue.

4229 Posts
Kadministrator
7 years ago
3
Level 10

Hi,

I did some tests and you can still apply limit, but you need to set pagination to Native. If Native is not desired setting in other instances you can override this in menu or in a module.

I made an issue on github to revert to old behavior, but there might be other reasons why this would not be possible so I suggest you use Native setting.

https://github.com/Octopoos/SEBLOD/issues/271

40 Posts
yoyoxp
7 years ago
2
Level 11

Cheers Klas! Native pagination setting does indeed work. Problem again is that limit will always equal pagination limit, so my Random Item module only pools very few of the items. Old 3.8.4 behaviour was the global Seblod limit and Seblod pagination limit values were independent.

Cheers

Nick

40 Posts
yoyoxp
7 years ago
1
Level 12

Is there any eta about when this functionality will be fixed?

Best regards,

Nick

40 Posts
yoyoxp
7 years ago
0
Level 13

Typically after posting the above, I managed to use the Joomla Native pagination workaround, while also have my random article module work ok. For anyone else interested here is the configuration:

- Seblod global options -> Pagination: I've set this to 25

- Pagination configuration for the Search & List view you want to apply limit to -> Set to Joomla Native

- for Random Content Module (Seblod List module set to randomized ordering, and limit one), under the advanced tab for Limit, enter a large number.

I have discovered this fixes the issues for me with this problem perfectly. I hope this helps someone else who may have run into the same problem!

Best regards,

Nick

Get a Book for SEBLOD